Jump to content


Photo

Invalid config option --kernel: Cannot specify a kernel with scrypt

error invalid config option kernel --kernel xubuntu scrypt linux

  • Please log in to reply
8 replies to this topic

#1 kopareczka-LTC

kopareczka-LTC

    Miner

  • Members
  • PipPip
  • 17 posts

Posted 28 August 2013 - 05:51 PM

Hey, I need your help! I was messing with my script and changed shaders and thread-concurrency a bit. When i tried to launch cgminer i got an error:

 

ltc@ltc:~$ ./litecoins.sh
 [2013-08-28 19:35:03] Invalid config option --kernel: Cannot specify a kernel with scrypt  
  

 

(I'm working on xubuntu 13.04, 64-bit)

So i used the backup of my script and it didn't work. I also used nano command to edit/create file with my old script, then changed the permission to execute it. Still the same:

ltc@ltc:~$ nano
ltc@ltc:~$ chmod +x litecoins.sh
ltc@ltc:~$ ./litecoins.sh
 [2013-08-28 19:20:07] Invalid config option --kernel: Cannot specify a kernel with scrypt

 

I was mining on this script for a month with no problems:

#!/bin/sh
export DISPLAY=:0
export GPU_MAX_ALLOC_PERCENT=100
export GPU_USE_SYNC_OBJECTS=1
cd /home/ltc/a
./cgminer --scrypt -o stratum+tcp://stratum2.wemineltc.com:3333 -u XXX -p XXX -I 16 --thread-concurrency 8192 --temp-target 78 --temp-overheat 90 --temp-cutoff 85 --auto-fan --gpu-fan 25-100 --gpu-engine 1050 --gpu-memclock 1500 --shaders 2048 --lookup-gap 2

(I have 6 Radeons 7950)

I have no clue what might have happened, I didn't change any other files...

Thanks in advance for help,
Cheers!



#2 giveen-LTC

giveen-LTC

    Hash Fixer

  • Members
  • PipPipPipPipPipPip
  • 1284 posts
  • LocationCaldwell, ID

Posted 28 August 2013 - 07:19 PM

What version of cgminer are you using?

 

https://github.com/c...driver-opencl.c

 

char *set_kernel(char *arg)

{
    enum cl_kernels kern;
    int i, device = 0;
    char *nextptr;
 
    if (opt_scrypt)
        return "Cannot specify a kernel with scrypt";
    nextptr = strtok(arg, ",");
    if (nextptr == NULL)
        return "Invalid parameters for set kernel";
    kern = select_kernel(nextptr);
    if (kern == KL_NONE)
        return "Invalid parameter to set_kernel";
    gpus[device++].kernel = kern;
 
    while ((nextptr = strtok(NULL, ",")) != NULL) {
        kern = select_kernel(nextptr);
        if (kern == KL_NONE)
            return "Invalid parameter to set_kernel";
 
        gpus[device++].kernel = kern;
    }
    if (device == 1) {
        for (i = device; i < MAX_GPUDEVICES; i++)
            gpus[i].kernel = gpus[0].kernel;
    }
 
    r

 


GPU: 2x XFX R9-270X + 1x 270 = 1.33MH/s

 

If you feel like I have helped you, please donate to LUagTzDc2WkSo5zGm6UBoMws6xgKMuQu5u , any amount is greatly appreciated.

Also setup litecoin mining configs, https://www.weminecr...itecoin-mining/

 

 


#3 kopareczka-LTC

kopareczka-LTC

    Miner

  • Members
  • PipPip
  • 17 posts

Posted 29 August 2013 - 05:24 PM

I'm running 3.3.1



#4 giveen-LTC

giveen-LTC

    Hash Fixer

  • Members
  • PipPipPipPipPipPip
  • 1284 posts
  • LocationCaldwell, ID

Posted 29 August 2013 - 05:35 PM

What happens when you run 3.4?


GPU: 2x XFX R9-270X + 1x 270 = 1.33MH/s

 

If you feel like I have helped you, please donate to LUagTzDc2WkSo5zGm6UBoMws6xgKMuQu5u , any amount is greatly appreciated.

Also setup litecoin mining configs, https://www.weminecr...itecoin-mining/

 

 


#5 kopareczka-LTC

kopareczka-LTC

    Miner

  • Members
  • PipPip
  • 17 posts

Posted 29 August 2013 - 06:05 PM

Still the same problem :(
ltc@ltc:~/cgminer-3.4.0-x86_64-built$ nanoltc@ltc:~/cgminer-3.4.0-x86_64-built$ chmod +x script_340.shltc@ltc:~/cgminer-3.4.0-x86_64-built$ ./script_340.sh [2013-08-29 20:03:18] Invalid config option --kernel: Cannot specify a kernel with scrypt ltc@ltc:~/cgminer-3.4.0-x86_64-built$
EDIT:
I also tried adding --kernel polcbm to the script. Practically nothing has changed:
[2013-08-29 20:15:29] ./cgminer: --kernel: Cannot specify a kernel with scrypt


#6 giveen-LTC

giveen-LTC

    Hash Fixer

  • Members
  • PipPipPipPipPipPip
  • 1284 posts
  • LocationCaldwell, ID

Posted 29 August 2013 - 07:11 PM

Very odd, and there is not much docmentation on it. Best bet, since no one is answering here, is to go to the litecoin forums and ask your question there.


GPU: 2x XFX R9-270X + 1x 270 = 1.33MH/s

 

If you feel like I have helped you, please donate to LUagTzDc2WkSo5zGm6UBoMws6xgKMuQu5u , any amount is greatly appreciated.

Also setup litecoin mining configs, https://www.weminecr...itecoin-mining/

 

 


#7 kopareczka-LTC

kopareczka-LTC

    Miner

  • Members
  • PipPip
  • 17 posts

Posted 29 August 2013 - 10:18 PM

I decided to reinstall the system. This --kernel thing is solved ofc, but now I have problems with mining itself. Had problems with cgminer 3.4.0, so I did a downgrade to 3.3.1. Didn't help - I cannot go above the intensity 12, which gives me ~200 kh/s on each card... Ridiculous, previously I could go up to 19, and at intensity set at 12 i had about 2x ~500mh/s and 4x ~700mh/s.
At least all of GPUs work equally now...

No idea what is happening here :blink: maybe I'll do another reinstall

Anyway, thanks



#8 samfisher-LTC

samfisher-LTC

    Miner++

  • Members
  • PipPipPipPip
  • 70 posts

Posted 02 September 2013 - 04:37 AM

Also just FYI, using thread concurrency overwrites the shaders command, so your shaders line isn't doing anything.



#9 deathxxx-FTC

deathxxx-FTC

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 11 October 2013 - 06:07 PM

Still the same problem :(

ltc@ltc:~/cgminer-3.4.0-x86_64-built$ nanoltc@ltc:~/cgminer-3.4.0-x86_64-built$ chmod +x script_340.shltc@ltc:~/cgminer-3.4.0-x86_64-built$ ./script_340.sh [2013-08-29 20:03:18] Invalid config option --kernel: Cannot specify a kernel with scrypt ltc@ltc:~/cgminer-3.4.0-x86_64-built$
EDIT:
I also tried adding --kernel polcbm to the script. Practically nothing has changed:
[2013-08-29 20:15:29] ./cgminer: --kernel: Cannot specify a kernel with scrypt

That seems you dont have cgminer compiled to use scrypt kernel.

You need recompile cgminer with scrypt support.

Use terminal and go to cgminer directory, then use this command:

 

rm *.bin

make clean
CFLAGS="-O2 -Wall -march=native" ./configure --enable-scrypt 

make







Also tagged with one or more of these keywords: error, invalid, config, option, kernel, --kernel, xubuntu, scrypt, linux